1 Introduction

An effective way of determining the correctness of a logic circuit is to simulate its behavior. This tutorial provides an introduction to such simulation using Altera’s simulation tool, called the *Simulation Waveform Editor*.

The simulation tool is used as part of the Quartus II CAD system, and is intended for students who are taking a course in logic circuit design. This tutorial shows how to use the Simulation Waveform Editor to perform a simulation of a circuit specified in Verilog HDL. Only a very basic understanding of Verilog is needed for this purpose.

Contents:

- Design Project
- Creating Waveforms for Simulation
- Simulation
- Making Changes and Resimulating
- Concluding Remarks
INTRODUCTION TO SIMULATION OF VERILOG DESIGNS
For Quartus II 13.0

The Simulation Waveform Editor is available for use with Altera’s Quartus II software version 13.0 or later. It allows the user to apply inputs to the designed circuit, usually referred to as test vectors, and to observe the outputs generated in response.

In this tutorial, the reader will learn about:

- Test vectors needed to test the designed circuit
- Using the Simulation Waveform Editor to draw test vectors
- Functional simulation, which is used to verify the functional correctness of a synthesized circuit
- Timing simulation, which is used to verify the timing of signals in a synthesized circuit

This tutorial is aimed at the reader who wishes to simulate circuits defined by using the Verilog hardware description language. An equivalent tutorial is available for the user who prefers the VHDL language.

2 Design Project

To illustrate the simulation process, we will use a very simple logic circuit that implements the majority3 function of three inputs, $x_1$, $x_2$, and $x_3$. The circuit is defined by the expression

$$f(x_1, x_2, x_3) = x_1 x_2 + x_1 x_3 + x_2 x_3$$

In Verilog, this circuit can be specified as follows:

```verilog
module majority3 (x1, x2, x3, f);
    input  x1, x2, x3;
    output f;
    assign f = (x1 & x2) | (x1 & x3) | (x2 & x3);
endmodule
```

Enter this code into a file called `majority3.v`.

The desired circuit has to be implemented in a Quartus II project. To do so, create a new directory (folder) for the Quartus II project, and for consistence with the description in this tutorial call it `simulator_intro`. Copy the file `majority3.v` into this directory. Then, create a Quartus II project and call it `majority3`. Compile your design.
3 Creating Waveforms for Simulation

To create test vectors for your design, select File > New... > Verification/Debugging Files > University Program VWF in the Quartus II window where the design project is open. This opens the Simulation Waveform Editor tool, shown in Figure 1, which allows you to specify the desired input waveforms.

![Figure 1. The Waveform Editor window.](image)

For our simple circuit, we can do a complete simulation by applying all eight possible valuations of the input signals $x_1$, $x_2$ and $x_3$. The output $f$ should then display the logic values defined by the truth table for the majority3 function.

We will run the simulation for 800 ns; so, select Edit > Set End Time in the Waveform Editor and in the pop-up window that will appear specify the time of 800 ns, and click OK. This will adjust the time scale in the window of Figure 1.

Before drawing the input waveforms, it is necessary to locate the desired signals in the implemented circuit. In FPGA jargon, the term “node” is used to refer to a signal in a circuit. This could be an input signal (input node), output signal (output node), or an internal signal. For our task, we need to find the input and output nodes. This is done by using a utility program called the Node Finder.

In the Waveform Editor window, select Edit > Insert > Insert Node or Bus. In the pop-up window that appears, which is shown in Figure 2, click on Node Finder.
The Node Finder window is presented in Figure 3. A filter is used to identify the nodes of interest. In our circuit, we are only interested in the nodes that appear on the pins (i.e. external connections) of the FPGA chip. Hence, the filter setting should be Pins: all. Click on List, which will display the nodes as indicated in the figure. In a large circuit there could be many nodes displayed. We need to select the nodes that we wish to observe in the simulation. This is done by highlighting the desired nodes and clicking on the > button. Select the nodes labeled $x_1$, $x_2$, $x_3$, and $f$, which will lead to the image in Figure 4. Click OK in this window and also upon return to the window in Figure 2. This returns to the Waveform Editor window, with the selected signals included as presented in Figure 5.
Observe that in Figure 5 all input signals are at logic level 0. The output, f, is shown as undefined. Next, we have to draw the input waveforms. Then, we will simulate the circuit, which will produce the output waveform.

To make it easier to draw the input waveforms, the Waveform Editor displays dashed grid lines. The spacing of the grid lines can be adjusted by selecting Edit > Grid Size, and in the pop-up box in Figure 6 specifying the desired size. The spacing of grid lines in Figure 5 is 10 ns. Another convenience in drawing is to have transitions of a waveform snap on grid lines. This feature is activated by clicking on the Snap to Grid icon.

Figure 5. Signals in the Waveform Editor window.
Input waveforms can be drawn in different ways. The most straightforward way is to indicate a specific time range and specify the value of a signal. To illustrate this approach, click the mouse on the \( x_1 \) waveform near the 400-ns point and then drag the mouse to the 800-ns point. The selected time interval will be highlighted in blue, as depicted in Figure 7. Change the value of the waveform to 1 by clicking on the Forcing High (1) icon, as illustrated in Figure 8.
In creating the waveform for \( x_1 \), we used the icon \( \text{Implement Value 1} \) to implement the logic value 1. Another possibility is to invert the value of the signal in a selected time interval by using the \text{Invert} icon. We will use this approach to create the waveform for \( x_2 \), which should change from 0 to 1 at 200 ns, then back to 0 at 400 ns, and again to 1 at 600 ns. Select the interval from 200 to 400 ns and click on the icon. Then do the same for the interval from 600 to 800 ns, as illustrated in Figure 9.

We will use a third approach to draw the waveform for \( x_3 \). This signal should alternate between logic values 0 and 1 at each 100-ns interval. Such a regular pattern is indicative of a clock signal that is used in many logic circuits. Even though there is no clock signal in our example circuit, it is convenient to specify \( x_3 \) in this manner. Click on the \( x_3 \) input, which selects the entire 800-ns interval. Then, click on the \text{Overwrite Clock} icon, as indicated in
Figure 10. This leads to the pop-up window in Figure 11. Specify the clock period of 200 ns and the duty cycle of 50%, and click OK. The result is depicted in Figure 12.

Figure 10. Drawing the waveform for $x_3$.

Figure 11. Defining the clock characteristics
Save the waveform file using a suitable name; we chose the name \textit{majority3.vwf}. Note that the suffix \textit{vwf} stands for \textit{vector waveform file}. VWF files that are added to the Quartus II project can be accessed at any time in the Project Navigator Widget’s Files tab.

4 Simulation

The Simulation Waveform Editor is able to use either ModelSim or Quartus II Simulator to simulate the circuit using the drawn waveforms. The simulator can be specified by selecting Simulation > Options. To use ModelSim as the simulator, ModelSim-Altera must be installed. If ModelSim-Altera is not installed, you must select Quartus II Simulator instead.

4.1 Functional Simulation

Now that we have created the input vector waveform, we can simulate the circuit. Select Simulation > Run Functional Simulation, or click on the icon $\mathbb{R}$. A pop-up window will show the progress of the simulation, then automatically close when it is complete. A second Simulation Waveform Editor window then opens the output waveform, as depicted in Figure 13. The output waveform is read-only, so any changes in simulation have to be done by modifying the \textit{majority3.vwf} file and resimulating the circuit. Observe that the output $f$ is equal to 1 whenever two or three inputs have the value 1, which verifies the correctness of our design.
4.2 Timing Simulation

To observe the actual propagation delays in our circuit, we have to perform a timing simulation. Select Simulation > Run Timing Simulation, or click on the icon 🔄. A pop-up window will show the progress of the simulation, then automatically close when it is complete. A second Simulation Waveform Editor window then opens the output waveform. The output waveform is read-only, so any changes in simulation have to be done by modifying the majority3.vwf file and resimulating the circuit.

The timing simulation shows that there are delays when signals change from one value to another. Figure 14 shows the waveform, zoomed in at 300ns to show the propagation delay between $x_3$ and $f$. The waveform indicates that the maximum delay is approximately 6ns.
5 Making Changes and Resimulating

Changes in the input waveforms can be made using the approaches explained above. The circuit can then be resimulated using the altered waveforms. For example, change the waveform for $x_1$ to have the logic value 1 in the interval from 100 to 240 ns, as indicated in Figure 15. Now, simulate the circuit again. The result is given in Figure 16. If errors in the circuit are discovered, then these errors can be fixed by changing the Verilog code and recompiling the design using the Quartus II software.
6 Concluding Remarks

The purpose of this tutorial is to provide a quick introduction to the Simulation Waveform Editor, explaining only the rudimentary aspects of functional and timing simulations. Details about additional features of the Simulation Waveform Editor can be found in the appendix of this document.

To learn about simulating circuits using ModelSim, please refer to the tutorials Introduction to ModelSim’s Graphical Waveform Editor, and Using ModelSim to Simulate Logic Circuits, which are available on Altera’s University Program website.
A Simulation Waveform Editor

In section 3 we introduced the Waveform Editor tool, which is used to view and edit waveforms that are used in simulation. Additional features of the Waveform Editor are described in this appendix.

A.1 Waveform Editor Toolbar

The Waveform Editor window is illustrated in Figure 1. The tool includes several commands which can be accessed by using the mouse, including File, Edit, View, Simulation, and Help. Below these commands, as shown in the figure, there is a toolbar that contains a number of icons which are useful when manipulating waveforms. This toolbar should be visible by default, but if it is not visible, then right-click near the top of the window (below the title bar) and select Waveform Editor in the menu that appears.

The toolbar icons are described below.

Selection Tool

This tool is used to select waveform intervals and apply changes. To make a selection, click on any part of a waveform and drag the blue box across the desired interval. It’s possible to select multiple waveforms at the same time, as shown in Figure 1, or select entire waveform(s) by clicking on its name(s).

Double clicking the selection tool anywhere on a waveform will select the largest interval with the same value from where the cursor points. Double clicking on a selected interval brings up the window to set arbitrary values for that interval.

Zoom Tool

This tool is used to zoom in or zoom out in the waveform display, as indicated in Figure 2. Left-clicking zooms into the display and right-clicking zooms out.
INTRODUCTION TO SIMULATION OF VERILOG DESIGNS

For Quartus II 13.0

Figure 2. Using the Zoom Tool.

Forcing Unknown (X)

This tool allows the selected part of a waveform to be set to the value Unknown (X). An example is given in Figure 3, using the majority3 function circuit that was described in section 2. The value of the signal x3 has been set to unknown for the first half of the simulation. Running the simulation with these input values results in the output waveform f that is shown in the figure. Note that the value of f is unknown between 200 to 400 ns.

Figure 3. Setting the value of an input to Unknown (X).

Forcing Low (0) and Forcing High (1)

These tools are used to force the selected part of a waveform to the value low (0) or high (1), as shown in Figures 4 and 5, respectively.
INTRODUCTION TO SIMULATION OF VERILOG DESIGNS

For Quartus II 13.0

Figure 4. Forcing $x_1$ to be low from 0 to 400 ns.

Figure 5. Forcing $x_1$ to be high from 400 to 800 ns.

High Impedance (Z)

This tool forces the selected waveform to the value High Impedance (Z), as shown in Figure 6. The high impedance value represents a signal that has not been set to any specific value—that is, an input pin that is not connected. Forcing output waveforms to have high impedance does not affect the output simulation waveforms.
**Weak Low (L)** $\text{XL}$ and **Weak High (H)** $\text{XH}$

These tools are used to set a signal to the values Weak Low (L) or Weak High (H), which represents a circuit in which a bidirectional signal is pulled down or up by using a resistor. Examples are shown in Figures 7 and 8.

![Figure 6. Setting a signal to high impedance.](image)

![Figure 7. Changing the $x1$ signal to be weak low from 200 to 400 ns.](image)
Introduction to Simulation of Verilog Designs

Figure 8. Changing the x1 signal to be weak high from 400 to 600 ns.

Invert

This tool inverts the value of a selected waveform, as shown in Figure 9. Low signals become high, weak low signals become weak high, and vice versa for both cases. The Invert tool has no effect on a signal that is set to high impedance or unknown.

Figure 9. Inverting the x1 signal from 100 to 260 ns.

Count Value

This tool allows a waveform to be partitioned into sections, in which the value is incremented by a specified amount. The Count Value tool can only be applied to a single waveform or a grouped waveform (see section B.1). The options that are available when using the Count Tool are illustrated in Figure 10.
INTRODUCTION TO SIMULATION OF VERILOG DESIGNS

As an example, Figure 11 shows the 3-bit input signal called count set to increment by one every 100 ns.

Overwrite Clock

This tool is used to generate a periodic waveform, which is often used as a clock signal. The options available when using the Overwrite Clock tool are shown in Figure 12.
INTRODUCTION TO SIMULATION OF VERILOG DESIGNS

Figure 12. Options available for the Overwrite Clock tool.

In the example of Figure 13, the $x_3$ signal has been generated with a period of 200 ns, an offset of 0 ns, and a duty cycle of 50%.

Figure 13. An example of using the Overwrite Clock tool.

Arbitrary Value

This tool allows a signal to be set to an arbitrary value, which is particularly useful for specifying the value of a multibit waveform. The options available when using the Arbitrary Value tool are shown in Figure 14.

Figure 14. Options available for the Arbitrary Value tool.
As an example, in Figure 15 the *count* signal is set to three different arbitrary binary values as specified by the user.

![Figure 15. The Arbitrary Value tool is used to set values for the count signal.](image)

**Random Values**

This tool assigns random values to the selected waveform(s), with several options as shown in Figure 16.

![Figure 16. Various options available for the Random Value tool.](image)

For example, in Figure 17, the signal \(x_1\) has been given random values.
Introduction to Simulation of Verilog Designs

Figure 17. An example of the Random Value tool being used.

Snap to Grid

This option allows selections made with the Selection Tool to snap to the light grey grid lines running vertically down the waveform display. This option can be toggled on and off by pressing the Snap to Grid button. It is set to on by default. Figure 18 shows an example of the Selection Tool being used with the Snap to Grid option turned off.

Figure 18. An example of the Snap to Grid option turned off.

Snap to Transition

This option allows the Selection Tool to automatically extend a selection to the first transition encountered on both sides of the selection of one or more waveforms. For example, with the Snap to Transition option turned on, the Selection Tool rectangle shown in Figure 19 would be expanded to create the selections illustrated in Figure 20. This option can be toggled on and off by pressing the Snap to Transition button, and is set to off by default.
B Using Multibit Signals

This section describes features of the Simulation Waveform Editor that are useful for dealing with multibit signals.

B.1 Grouping and Ungrouping Signals

Individual signals can be grouped together to create a multibit waveform. This is done by first selecting the desired waveforms by clicking on their names in the leftside of the Waveform Editor with the key Ctrl pressed as indicated in Figure 21. Then, as shown in the figure, the grouping of signals is done by right-clicking on the selection and choosing Grouping > Group....
Figure 21. An example of grouping signals.

In the options dialogue that opens, illustrated in Figure 22, a name must be assigned to the group, as well as a radix. In the example shown, the name *count* has been chosen with a binary radix.

Figure 22. Select a name and radix for the group of signals.

The resulting group of signals is shown in Figure 23. The multibit waveform can be expanded in the waveform editor to display its individual signals.
INTRODUCTION TO SIMULATION OF VERILOG DESIGNS

For Quartus II 13.0

A multibit signal can be ungrouped by right-clicking on the group of signals and selecting Grouping > Ungroup....

It is also possible to create hierarchical groupings of signals as illustrated in Figure 24. In this example, the two bit signal called level2 is combined with the signal called \( x_3 \) to create the three bit signal called level1. It is only possible to group and ungroup top-level signals.

It is also possible to group input and output signals, as shown in Figure 25.

Figure 23. An example of expanding a multibit signal.

Figure 24. An example of hierarchical groups.

Figure 25. An example of grouping input and output signals.
B.2 Reverse Group or Bus Bit Order

In Figure 23, the three bit signal count is displayed as the 3-tuple $x_1, x_2, x_3$. It is possible to reverse the order in which the bits are displayed as illustrated in Figure 26. This is done by right-clicking on the name of the multibit signal and selecting Reverse Group or Bus Bit Order, as seen in the figure.

The effects of the bit reversal can be seen in Figure 27. The count waveform is now displayed as the 3-tuple $x_3, x_2, x_1$. 
Figure 27. The result of reversing the bit order in Figure 26.
INTRODUCTION TO SIMULATION OF VERILOG DESIGNS

Copyright ©1991-2013 Altera Corporation. All rights reserved. Altera, The Programmable Solutions Company, the stylized Altera logo, specific device designations, and all other words and logos that are identified as trademarks and/or service marks are, unless noted otherwise, the trademarks and service marks of Altera Corporation in the U.S. and other countries. All other product or service names are the property of their respective holders. Altera products are protected under numerous U.S. and foreign patents and pending applications, mask work rights, and copyrights. Altera warrants performance of its semiconductor products to current specifications in accordance with Altera’s standard warranty, but reserves the right to make changes to any products and services at any time without notice. Altera assumes no responsibility or liability arising out of the application or use of any information, product, or service described herein except as expressly agreed to in writing by Altera Corporation. Altera customers are advised to obtain the latest version of device specifications before relying on any published information and before placing orders for products or services.

This document is being provided on an “as-is” basis and as an accommodation and therefore all warranties, representations or guarantees of any kind (whether express, implied or statutory) including, without limitation, warranties of merchantability, non-infringement, or fitness for a particular purpose, are specifically disclaimed.